Лишний тег?

Обсуждение материалов (глав) сайта webremeslo.ru

Лишний тег?

Сообщение Полина » 15 июн 2013, 16:40

Похоже я здесь буду много спрашивать, т.к. на "Введение" уже застряла))
Написала в блокноте,как написано в учебнике, открываю в браузере и в конце всех моих слов стоит закрывающий тег </html>. Не сказать,что я совсем не сталкивалась с html, потому знаю,что такого не должно быть. Может это у меня комп не требует этого тега? Проверяла на 2-ух разных браузерах. Писала точно как в учебнике. Из-за чего так может быть?
Полина
 
Сообщения: 4
Зарегистрирован: 15 июн 2013, 16:23

Re: Лишний тег?

Сообщение Nikel097 » 15 июн 2013, 16:54

я здесь буду много спрашивать

Ничего страшного. Все учатся.
и в конце всех моих слов стоит закрывающий тег </html>

Можете показать ваш код?
Аватара пользователя
Nikel097
 
Сообщения: 276
Зарегистрирован: 04 июн 2012, 12:27
Откуда: Казахстан, Алматы

Re: Лишний тег?

Сообщение Полина » 15 июн 2013, 17:02

Когда его убираю,то всё нормально.
Мой код? В смысле,как написано в блокноте?
<html>
<head>
<title>Моя страничка </title>
</head>
<body>
О\
<br>
бла-бла,слова всякие
</body>
</html>
Когда пишу без "/", то тоже всё нормально.
Полина
 
Сообщения: 4
Зарегистрирован: 15 июн 2013, 16:23

Re: Лишний тег?

Сообщение Nikel097 » 15 июн 2013, 17:34

Мой код? В смысле,как написано в блокноте?

Он самый.
У Вас нет ошибок.
А какое у Вас разрешение файла (должно быть .html).
Аватара пользователя
Nikel097
 
Сообщения: 276
Зарегистрирован: 04 июн 2012, 12:27
Откуда: Казахстан, Алматы

Re: Лишний тег?

Сообщение Полина » 15 июн 2013, 17:40

ну естественно - html..)
Полина
 
Сообщения: 4
Зарегистрирован: 15 июн 2013, 16:23

Re: Лишний тег?

Сообщение Nikel097 » 15 июн 2013, 17:54

Я не знаю. У меня таких проблем никогда не было.
Может дело в кодировке, хотя врятли.
Аватара пользователя
Nikel097
 
Сообщения: 276
Зарегистрирован: 04 июн 2012, 12:27
Откуда: Казахстан, Алматы

Re: Лишний тег?

Сообщение Алексей » 16 июн 2013, 12:30

Тот код который Вы выложили здесь написан правильно я его скопировал, сохранил, открыл в браузере ничего лишнего не отображается! Почему у Вас так происходит не знаю но явно где-то ошибка.. Код который вы выложили здесь именно тот код что у вас некорректно работает? или вы здесь написали его заново а не копировали? Обычно браузер выводит теги на экран если те написаны с ошибками, опечатками.. кириллицей.. лишними пробелами.. или если Вы дважды в коде написали закрывающий тег </html>. Но повторяю с кодом который Вы выложили здесь проблем нет.
Аватара пользователя
Алексей
Администратор
 
Сообщения: 834
Зарегистрирован: 03 апр 2010, 09:12
Откуда: Солнечный Геленджик :)

Re: Лишний тег?

Сообщение Encoder » 17 июн 2013, 02:43

Проверил валидатором, нету ошибок. Ошибки вообще тут нету, может глюк какой нибудь? :)?

Если попробовать так:

Код: Выделить всё
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<title>Моя страничка </title>
</head>
<body>
О\
<br>
бла-бла,слова всякие
</body>
</html>
Аватара пользователя
Encoder
Модератор
 
Сообщения: 360
Зарегистрирован: 21 фев 2011, 11:15

Re: Лишний тег?

Сообщение Полина » 20 июн 2013, 11:44

Может, нужно просто копм на вирусы просканировать..)
Полина
 
Сообщения: 4
Зарегистрирован: 15 июн 2013, 16:23

Re: Лишний тег?

Сообщение Encoder » 20 июн 2013, 14:20

Тут дело не в вирусах.
Аватара пользователя
Encoder
Модератор
 
Сообщения: 360
Зарегистрирован: 21 фев 2011, 11:15

След.

Вернуться в Учебники

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron
Рейтинг@Mail.ru